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1 INTRODUZIONE  

Il software M1 Tune permette il collegamento tra PC e centralina MoTeC M1. 
 
Alcuni concetti di base e la seguente terminologia faciliteranno l’apprendimento: 
 

• Una centralina M1 viene configurata attraverso l’utilizzo di un file chiamato "PACKAGE” 
 

• Un “PACKAGE” è la mappa che viene caricata all’interno della ECU. 
In dettaglio contiene: 
 

- Firmware  
- Calibrazione (tuning)  
- Configurazione dell’acquisizione  
- Configurazione di accesso utente 
- Layout grafico  

 

• Ogni pacchetto M1 è destinato a uno specifico modello di ECU M1 (M130) 
 

• Ogni pacchetto M1 include un “HELP” integrato specifico per l'applicazione prevista 
 

• I pacchetti possono essere aggiornati alle nuove versioni del firmware non appena disponibili 
 

• M1 Tune è generico e può essere utilizzato con qualsiasi pacchetto M1 o modello ECU M1 
 
M1 Tune ha un aspetto grafico simile a quello del software di analisi MoTeC I2 e viene utilizzato per 
configurazione, analisi e calibrazione dei parametri. L'applicazione consente la creazione e 
personalizzazione dei layout grafici dello schermo per una calibrazione motore più semplice e veloce. 

 
Figura 1- Esempio schermata M1Tune 
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2 REQUISITI DI SISTEMA 

Sistema operativo: Windows XP, Vista, Win7, Win8, Win10 (32 e 64 bit) 
 
Risoluzione minima dello schermo: 1024 x 768 
 
Porta di comunicazione: porta Ethernet 
 
Protocollo di comunicazione: IPV6 
 

3 INSTALLAZIONE SOFTWARE M1 TUNE 

Il software M1 Tune è disponibile per il download dal sito Web MoTeC all'indirizzo: 
 

http://www.motec.com.au/software/latestreleases/ 
 
Una volta installato il software, l'icona M1 Tune è disponibile dal desktop.  
Utilizzare questa icona per avviare il software M1 Tune. 

 
Importante: 
Se durante l'installazione, viene richiesto di consentire modifiche al tuo PC dal software MoTeC, mettere 
la spunta su consenti sempre; altrimenti la comunicazione tra PC ed ECU non funzionerà. 

 

3.1 Controllo Aggiornamenti 

M1 Tune è in continua evoluzione. Gli aggiornamenti del sistema sono disponibili automaticamente 
all’interno del software.  
Se compare una icona nel lato alto dello schermo con due frecce, fare doppio-click per vedere 
aggiornamenti disponibili 
 

 
Figura 2-Esempio icona aggiornamento 

  

http://www.motec.com.au/software/latestreleases/
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4 COLLEGAMENTO ECU AL PC 

La centralina MoTeC M1 utilizza una connessione ethernet per la comunicazione tra centralina e 
computer.  
Si consiglia di utilizzare cavi categoria CAT 5E o superiore durante realizzazione collegamento. 
 
Nota: 
Si consiglia di cablare i cavi ethernet in modalità “crossover”.  
In questo modo, è possibile utilizzare un cavo Ethernet standard (non incrociato) per tutte le 
comunicazioni tra l'ECU e il PC. 

4.1 Pin-out per la comunicazione con la ECU 

Il pin-out del connettore ethernet è mostrato nella tabella seguente: 
 

PIN FUNZIONE 

1 Ethernet RX + 

2 Ethernet RX - 

3 Ethernet TX + 

6 Ethernet TX - 

 

4.2 Risoluzione dei problemi di collegamento 

Quando la centralina è connessa la PC, la vedrai apparire automaticamente nella lista delle ECU 
connesse all’interno di M1Tune nel tab Quick Launch o nella finestra ECU Select: 
 

 
                     Figura 4-Finestra ECU Select 

 
 
 

Figura 3a-Finestra Quick Launch 
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Se la centralina non compare nell'elenco, attenersi alla seguente procedura per risolvere la causa del 
problema di comunicazione. 
 
1.  Le porte Ethernet normalmente includono spie LED. Controllare se sono accese (normalmente 
lampeggiano, per indicare il traffico dati sul cavo) quando la ECU è collegata e accesa.  
 

 
Figura 5-Esempio led  porta ethernet 

Se la centralina è accesa e le luci non lampeggiano, molto probabilmente c’è un problema nelle 
connessioni del cavo Ethernet 

 
2. Se il cablaggio ethernet è corretto e non è ancora presente alcuna comunicazione: 
 
a) Disabilitare temporaneamente tutte le applicazioni antivirus e firewall 
 
b) Mentre M1 Tune è aperto assicurarsi che il servizio di rilevamento dispositivi MoTeC sia aperto e 

funzionante. Per controllare che MoTeC Device Discovery sia in esecuzione, fare doppio click 
sull’icona come raffigurato qui di seguito 

 

 
Figura 6-Icona MoTeC Device Discovery 

 
c) Riavviare M1 Tune e tentare di stabilire comunicazioni con la ECU. 
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5 AVVIO M1 TUNE 

All'avvio del software, la finestra di Quick Launch apparirà dal lato sinistro dello schermo. 
Dalla finestra Quick Launch è possibile connettersi ad una ECU o aprire un pacchetto offline.  
 
 
 
 
 
 
 
 
 
 
 
 
Altre opzioni disponibili sono la possibilità di scaricare i dati acquisiti (la ECU deve essere collegata 
affinché questa opzione funzioni) e aprire i packages offline. 
Facendo doppio click sulla ECU si accede ai parametri di calibrazione e tuning. 
 

 
Figura 8-Esempio schermata ECU connessa 

 

6 PANORAMICA SUI PACKAGE E LAYOUT 

Package è il nome utilizzato per descrivere il set completo di dati per un’applicazione, mentre i layout si 
riferiscono al modo in cui i dati vengono visualizzati nell'interfaccia grafica di M1 Tune. 
 

• Una centralina può contenere solo un Package. 

• Se un nuovo Package viene inviato alla centralina, sostituisce completamente tutto il package 
precedente. 

• Un Package inviato su una ECU collegata a M1 Tune può essere lavorato in modalità realtime. 

• I Package salvati sul PC sono apribili come Package offline. 

Figura 7-Quick Launch 
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 6.2 Contenuto del package 

Un Package contiene: 
- Firmware  
- Calibrazione (tuning)  
- Configurazione dell’acquisizione  
- Configurazione di accesso utente 
- Layout grafico  

 
All’apertura di un Package vengono visualizzati sempre 3 elementi che consentono di eseguire il tuning: 
Canali, Parametri e Tabelle. 
 

Oggetto Segmento del Package Definizione 

 
Canali 

     
Definiti dal Firmware 

Un canale è una variabile di 
sistema che viene scritto nel 
firmware. I canali non possono 
essere modificati dall’utente.  
Un esempio di un canale è la 
posizione dell’acceleratore. 

 
Parametri 

 
Definiti dal Firmware 
Valori inseriti dall’utente 
 

Un parametro è un valore 
definito che può essere 
modificato dall'utente in M1 
Tune.  
Un esempio di parametro è il 
rapporto di trasmissione. 

 
Tabelle 

 
Definiti dal Firmware ( assi e 
numero di breakpoint ) 
Valori inseriti dall’utente 
 

Le tabelle sono una 
componente di base utilizzate 
da molte strategie di controllo 
come: gestione carburante, 
accensione e controllo del 
cambio. 
La tabella è composta da un 
numero di assi preconfigurati. 
Gli assi possono essere abilitati 
o disabilitatati, spostati di 
posizione, nonché modificato il 
contenuto della tabella. 
Questo è uno dei modi 
principali per configurare la 
centralina M1.  
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6.2 Apertura package offline 

La finestra Open Package fornisce informazioni, accesso ai dettagli del Package, filtro e storia.  
I Package salvati sul PC possono essere aperti come segue: 

Selezionare File » Open Package oppure selezionare Browse Packages da Quick Launch 

 
 

 
Figura 9-Esempio finestra Open Package 

 
1. Identificare e selezionare il Package richiesto utilizzando i dettagli del pacchetto, i filtri e la cronologia 
2. Selezionare il pulsante Open 
3. Il Package selezionato si apre. 
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6.3 Dettagli del package 

La finestra Open Package visualizza un elenco di Package offline disponibili. I dettagli dei Package 
vengono mostrati nella parte laterale della schermata. 
 
 

Dettagli Definizione 

State Indicato dalle icone. 

 
Vehicle ID 

Un identificatore univoco del veicolo in cui viene 
utilizzato il Package. Vehicle ID 
è un modo utile per trovare Package specifici per 
un determinato veicolo. 

 
 
 

Serial # 

Rappresenta il numero di serie della ECU 
associato al Package. Ogni volta che un 
Package viene inviato a una ECU, M1 Tune 
controllerà di inviarlo alla centralina 
corrispondente. Se il Package deve essere 
inserito in un'altra ECU, allora il numero seriale 
deve essere cambiato con il numero seriale della 
nuova ECU. 

Comment I commenti vengono utilizzati per tenere traccia 
delle modifiche all’interno del Package nel 
tempo.  

Firmware Versione di firmware 
 

Firmware 
Version Name 

Utilizzato per descrivere la versione specifica del 
firmware 

Firmware 
Version 

Un numero crescente che rappresenta in modo 
univoco ogni evoluzione del firmware 

 
 

Hardware 

Questo campo identifica per quale modello di 
ECU M1 è stato creato il Package. Ogni Package 
è progettato per funzionare con un particolare 
modello M1.  

Modified 
Date/Time 

Questo campo registra l'ultima volta in cui il 
Package è stato modificato 

Imported 
Date/Time 

Questo campo registra la data e l'ora in cui il 
pacchetto è stato importato su PC. 
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6.4 Opzioni di filtro del package 

Le opzioni di filtro fornite nella parte sinistra della finestra Open Package possono essere molto 
utile per aiutare a trovare un Package specifico. 
 
Nota: 
Quando si lavora su un Package, aggiornare il Vehicle ID e la descrizione mentre si procede in modo 
che la funzione di filtro sia veramente efficace. 
Questo è importante per facilitare la ricerca e l'ordinamento delle versioni del Package. 

 
Opzione di filtro Risultato 

All Mostra tutti i Package sul PC (nessun filtro) 

Recently imported Elenca tutti i Package  ordinati per i più recenti 
importati in   M1 Tune 
 

Recently Modified Elenca tutti i Package ordinati per il più 
recentemente modificato dall'interno di M1 Tune 
 

By Firmware Mostra tutti i Package raggruppati per nome 
firmware 
 

By Hardware Mostra tutti i Package raggruppati in base al 
modello hardware M1 
 

By ECU Mostra tutti i Package raggruppati per tipo di 
ECU e numero di ECU 
 

By Vehicle Id Mostra tutti i Package raggruppati per Vehicle ID  
 

 

6.5 Storia del package 

La finestra Open Package mostra la cronologia di ciascun Package. Questa cronologia viene visualizzata 
utilizzando un Graphical State Tree. 
Esso utilizza caselle colorate per indicare lo stato di un pacchetto e linee di collegamento ad indicare 
l’importanza del Package 
Usando queste righe è possibile determinare da dove è stata originato una particolare versione di un 
Package. 
Nella parte inferiore della finestra Open Package sono visualizzati i sette stati possibili. 
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State Definition Example State 
Tree 

Light orange - Unknown M1 Tune non può determinare l'origine di 
questo Package 

 

Cyan - Auto Saved Un Package modificato che non è mai stato 
salvato dall'utente, M1 Tune salva 
automaticamente i Package ogni minuto 

Blue - Tuned Un Package che è stato modificato offline 
ma non inviato ad una ECU 

Green - Matched ECU Un Package che corrisponde ad un altro 
presente in una ECU 

Dark orange - Migrated Un Package che è stato modificato in base 
a un altro Package 

Purple - Merged Questo scenario si verifica quando ci sono 
più persone che lavorano su una singola 
ECU e quindi le modifiche apportate si 
“sovrappongono”. 

Red - Partial Merge In alcuni casi, una migrazione completa 
non può avvenire con successo perché due 
utenti hanno cambiato la stessa parte del 
pacchetto (causando un conflitto che non 
può essere automaticamente 
risolto); ma alcuni dei dati sono stati copiati. 
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7 MANIPOLAZIONE DEI PACKAGES 

Si consiglia di spostare/modificare i file Package M1 tramite la finestra Open Package.  
I Package MoTeC M1 non devono essere copiati, aggiunti, cancellati o spostati mediante l'uso di 
file system standard di Windows. Quando si spostano i file del Package, si consiglia di usare le funzioni 
Import/Export ed Export Mail disponibili nella finestra Open Package. 
Utilizzare le funzioni di importazione ed esportazione quando è necessario spostare un Package da un 
PC ad un altro. 

7.1 Archiviazione File 

MoTeC ha implementato un nuovo tipo di file chiamato M1 Archive per aggiungere e spostare Package 
all'interno di M1Tune. 
M1 Archive può contenere più file e strutture di directory complete, è simile ad un file ZIP 
autoestraente. Le posizioni vengono determinate automaticamente quando viene estratto il file, non 
richiede input da parte dell'utente. 
Gli archivi utilizzati all'interno di M1 Tune sono descritti in questa tabella. 
 

Estensione del file Significato 

.m1pkg-archive File necessari per aggiungere un nuovo pacchetto a 
M1 

.m1prj-archive Tutti i file richiesti per un intero progetto M1 

.m1lic-archive File di licenza M1 

.m1wsp-archive File necessari per installare un nuovo worspace 

 

Esempio: se si esporta un Package esso viene salvato in formato m1prj-archive 

7.2 Esportazione del package 

Per esportare Package: 
 
1. Aprire la finestra Open Package dal menu a comparsa Quick Launch o dall'opzione di menu  

File » Open Package. 
 

2. Utilizzando i filtri e le ricerche necessarie, trovare e selezionare il Package da esportare. 
 

3. Selezionare il pulsante Export File per esportare l'archivio su una chiavetta USB o su un'unità disco 
oppure su Export Mail per allegare l'archivio a un'e-mail. 

• Il file creato ha un'estensione di .m1pkg-archive. Il nome file è una combinazione di firmware, 
hardware, ID veicolo. 

 
4. Distribuire il file di archivio del Package come richiesto. 
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7.3 Importazione dei package 

Una volta ricevuto l'archivio del Package, sono disponibili due opzioni per l'installazione (importazione) 
del pacchetto: utilizzare la funzione di importazione come descritto di seguito o fare doppio clic sul 
nome file dell'archivio ( metodo consigliato ). 
 
Entrambi i metodi comportano la decompressione automatica del pacchetto e l'aggiunta dei file nelle 
posizioni corrette così il pacchetto diventa disponibile nella finestra Open Package. 
 
Metodo manuale: 
1. Aprire la finestra Open Package dal menu a comparsa Quick Launch o selezionando il menu 

opzione File » Open Package 
 

2. Selezionare il pulsante Import File 
 

3. Selezionare file di archivio e fare clic su Open 

7.4 Eliminazione dei package 

Per eliminare i Package: 
 
1. Aprire la finestra Open Package dal menu a scomparsa Quick Launch o selezionare il menu 
opzione File » Open Package.. 
 
2. Selezionare il Package da eliminare (è possibile selezionare anche più pacchetti) e fare clic con il 

tasto destro del mouse → selezionare Delete 
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8 LAYOUT GRAFICI 

Un Package è costituito da varie sezioni grafiche di layout: 
 

• Workbooks 

• Worksheets 

• Worksheet components 
. 

 

8.1 Workbooks 

I Workbook sono utilizzati per separare diverse funzioni all’interno del Package.  
 
 

 
Figura 10-Esempio dii Workbook selezionato 

 
Nota: 
Mantenere separate le aree funzionali è il metodo raccomandato per l'utilizzo di M1 Tune, ciò consente 
una facile identificazione di un'area funzionale quando si lavora sul Package. 
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8.2 Worksheets 

Un Worksheet può essere considerato come una pagina del Workbook. Per comprendere i vantaggi di 
questa relazione, tutti i Worksheets devono essere strettamente correlati al nome del Workbook. 
 
 

 
Figura 11-Esempio di differenti Worksheet 

 
Ad esempio, un Workbook chiamato Fuel potrebbe contenere i fogli di lavoro relativi alla configurazione 
dell'iniettore di carburante, controllo della pompa, calibrazione del combustibile, impostazione dei 
transitori di combustibile, regolazione del combustibile, controllo della pressione del combustibile. 
Invece nel Workbook chiamato Ignition, i fogli di lavoro appropriati potrebbero riguardare: tempi di 
accensione bobina, anticipo accensione, strategia taglio dell'accensione, compensazioni dell'accensione 
del singolo cilindro. 
 

 

Per avere un’idea di come è strutturato graficamente il Package fare click su ‘Layout’ nella barra a sinistra 
sotto Quick Lunch: 
 

 
Figura 12-Esempio struttura ad albero con evidenziati Workbooks e Workspaces 
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8.3 Layout di default e modifica 

 
Un layout predefinito è appositamente progettato per semplificare al massimo l'utilizzo del Package. 
Questo significa che quando ci si collega ad una ECU viene già aperto un layout grafico predefinito. 
 
L’utente ha la possibilità di modificare il layout seguendo la procedura: 
 

• Premere di destro sulla radice dell’albero → Cliccare su UNLOCK 

• A questo punto premendo di destro su un Workspace libero si può modificare o aggiungere degli 
elementi di layout 

 
 

 
       

 

 

 

 

 

 

                          Figura 13-Aggiungere un elemento di layout 

 

 

   Figura 14-Sbloccare un layout 

8.4 Creazione di Workbook 

Per creare nuovi Workbooks: 
 
1. Eseguire Unlock del layout 

 
2. Selezionare l'opzione di menu Layout » New Workbook. 

 
3. Denominare il nuovo Workbook. 

◆ Viene creata un nuovo Workbook vuoto. 
 

4. Aggiungi Worksheets e componenti come desiderato. 
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8.5 Creazione di Worksheet 

Un nuovo Worksheet viene creato vuoto. L'utente può quindi riempire il Worksheet con una varietà di 
componenti che possono essere posizionati ovunque per creare layout personalizzati.        
I componenti stessi possono essere spostati, ridimensionati e personalizzati. 
Ogni componente ha un set unico di proprietà specifiche.  
Queste proprietà determinano l'aspetto e il comportamento.  
 
Lo stesso tipo di componente può essere utilizzato su più Worksheet/Workbook con proprietà diverse. 
 

I tipi di componenti disponibili includono:  
 

• Calibrate                                                                              

• Table Target 

• Channel List 

• Time Graph 

• Scatter Plot 

• Histogram 

• Colour Graph 

• Notes 

• Gauges 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Figura 15-Esempi di componenti 
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8.5.1 Lista Calibrate 

Calibrate list contiene i canali e i loro valori. 
 
I canali visualizzati in questo elenco sono regolati dal tipo di elenco selezionato.  
 
Il modo in cui l'elenco visualizza le informazioni può essere regolato utilizzando la barra degli strumenti 
(situata in cima all'elenco a sinistra)  
 
                                                       

 
Figura 16-Calibrate Component 

 
Di seguito sono descritte le opzioni disponibili: 
 

 

 
 

Cambia la modalità di visualizzazione dell’albero in flat o 
viceversa. 

 

 
 

Attiva e disattiva i valori dei canali. Se questa opzione è 
attivata, l'elenco include i valori in tempo reale di qualsiasi 
genere di canale. 

 

 
 

Limita l'elenco per mostrare solo gli elementi attualmente non 
validi. 
Gli elementi non validi sono tabelle o canali che contengono 
valori che non soddisfano i loro criteri di validazione. Questi 
elementi dovrebbero normalmente essere corretti prima di 
avviare il motore. 

 

 
 

Quando si è in modalità di confronto (confrontando un 
Package con un altro), l'elenco Calibrate indica ciò che è 
uguale e ciò che è diverso tra i due pacchetti. Selezionando 
questa opzione si limita l'elenco nel mostrare solo gli elementi 
diversi. 

 

 
 

Permette di cercare nell'elenco corrente qualsiasi elemento 
che corrisponda alla descrizione inserita 
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Aprendo le proprietà della lista Calibrate si può decidere cosa visualizzare: 
 

 
Figura 17-Calibrate Properties 

 

Item Selection - All Items Mostra tutti gli elementi del Package 

Item Selection - Matching Items Limita gli elementi nell'elenco abbinate ad una 
specifica parola chiave.  

Item Selection - User defined Items Limita le voci nell'elenco visualizzando solo le voci 
definite 

 
È inoltre possibile configurare colori, limiti e altre impostazioni di visualizzazione. 
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8.5.2 Tabella 

Le tabelle possono essere visualizzate in diverse modalità e fanno parte degli elementi visualizzati nella 
lista calibrate. 
 
Per scorrere tra le visualizzazioni: 
 

• Selezionare il componente Calibrate ( barra in alto si evidenzia in arancione ) 

• Premere G per scorrere tra le tre viste ( solo tabella, tabella+grafico, solo grafico ) 

• Per espandere la vista a schermo intero premere F6. 

• Ripremere F6 per ritornare alla vista normale 
 

 
 

 
 
 
 
 
 
 

 

 

 

Figura 18-Differenti viste tabella 
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Esistono tre aspetti fondamentali delle tabelle: 
 

• Configurazione assi tabelle 

• Interpolazione dati 

• Importare ed esportare dati tabelle 

8.5.3 Configurazioni assi tabella 

Ogni tabella può avere fino a tre assi. I canali degli assi possono essere attivati o disattivati ma non 
cambiati. 
 
È possibile: 
 

• Modificare i berakpoint degli assi 

• Attivare uno, tutti o nessuno degli assi 

• Scambiare gli assi 

• Invertire l'ordine degli assi 
 

8.5.4 Proprietà assi tabella 

Per visualizzare le opzioni degli assi tabella, premere con il pulsante destro sulla tabella e spostare il 
cursore sulla voce Axis 

 

 
Figura 19-Schermata Setup Assi 
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Per modificare i breakpoint degli assi: 
 

• Evidenziare la tabella e premere A, oppure fare clic con il tasto destro del mouse sulla tabella e 
selezionare Axis » Setup Axis 

 
 
                                            

 
Figura 20-Schermata setup assi 

8.5.5 Inserimento valori tabella 

Quando viene selezionata una tabella, esistono diverse modalità su come inserire i valori: 
 

Direct entry 1. Seleziona la cella. 
2. Digitare il numero e premere Invio. 
Premere Esc per annullare l'immissione 

Increment / Decrement 
the table value 

1. Seleziona la cella o la zona 
2. Premere Page up per aumentare i valori nella selezione o 
Premere Page down per ridurre i valori a intervalli medi. 

Increment / Decrement 
the table value Fast 

Per quanto riguarda l'incremento / decremento del valore 
della tabella utilizzare CTRL + Page up per modificare i 
valori in passaggi più grandi 

Increment / Decrement 
the table value Slow 

Per quanto riguarda l'incremento / decremento del valore 
della tabella utilizzare nuovamente CTRL + Page down per 
modificare i valori in passaggi più piccoli. 

 
 
 

1. Seleziona la cella o la zona 
2. Premere = per visualizzare una finestra di espressione 
matematica. 
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Scale or Offset 
 

3. Immettere un'espressione da eseguire sulla selezione.  
Per esempio: 

 
 

 
  

8.5.6 Importare ed esportare tabelle 

Premendo il tasto destro del mouse sulla tabella, si hanno diversi opzioni per importare/esportare: 
 

 
 
 
Export »Entire Table »To File... 
OR 
Import »Entire Table »From File... 

Esporta o importa la tabella completa, i suoi assi 
e valori degli assi. Queste tabelle sono in un 
formato che non può essere modificato al di fuori 
di M1. 
Nota: 
Questo è l'unico modo per copiare una tabella con 
3 assi in un solo passaggio, ed è il metodo 
preferito per la copia di tabelle da un Package 
all’altro. 

 
Export »Current View »To CSV File... 
OR 
Export »Current View »To Clipboard 

Esporta solo gli attuali 2 livelli visualizzabili (assi) 
di una tabella a 3 assi o l'intera tabella per 2 e 1 
asse in altra tabella. Questi dati possono essere 
esportati negli appunti per una copia veloce o in 
un file CSV se deve essere inviato o modificato al 
di fuori di M1 Tune. 

 
Import »Current View »From CSV File... 
OR 
Import »Current View »From Clipboard 
 

 
Importa i livelli di tabella esportati utilizzando 
esporta la funzione di visualizzazione corrente. 
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8.5.7 Copiare e incollare dati tabella 

Quando si utilizza l'applicazione M1 Tune, potrebbe essere necessario copiare e incollare parte di una 
tabella. Le funzioni da utilizzare sono Copy Data e Paste Data. 
 
Nota: Questo è l'unico metodo disponibile per copiare e incollare le selezioni dei dati della tabella. Le 
funzioni Taglia, Copia e Incolla di Windows non funzioneranno per i dati della tabella, Il sistema è 
progettato per agire solo a livello di componente.   
 
Copy Data: Copia solo i valori della tabella selezionata, non copia gli assi o nessuno altre informazioni 
della tabella. 
 
Paste Data: Incolla i dati copiati  
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8.5.8 Interpolazione dati tabella 

 
Esistono 4 diversi tipi di interpolazione: 
 

Interpolate 
(bi-linear) 

Prende i valori degli angoli dall'area selezionata e interpola sia le righe 
che le colonne a partire dagli elementi selezionati. 

Interpolate 
Vertically 

Prende il valore superiore e inferiore e distribuisce uniformemente i 
valori intermedi. 

Interpolate 
Horizontally 

Prende il valore sinistro e destro e distribuisce uniformemente i valori 
intermedi 

 
Smooth 
 

Quando viene selezionata una singola riga, la funzione smooth esegue 
lo smooth dei valori sinistro e destro di ciascun punto. Fare lo smooth di 
un blocco significa: prendere ogni valore del blocco ed eseguire un 
livellamento ponderato da ciascun sito circostante; il peso maggiore è 
dato ai valori verticali e orizzontali, meno agli angoli esterni 

 
Per applicare l'interpolazione: 
1. Selezionare l'area richiesta. 

◆ Fare clic con il tasto destro del mouse sulla selezione:Viene visualizzato il menu dedicato  
 
2. Seleziona Adjust » [required option] 

 

 
Figura 21-Finestra Interpolazione 
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8.5.9 Contrassegnare cella come modificata 

È possibile contrassegnare una cella o un intervallo come "Tuned". Poiché il valore è considerato 
ottimizzato, la funzione interpolazione non modificherà questi valori. 
1. Selezionare i valori della tabella. 
2. Premere Backspace 

◆ I siti sono contrassegnati da un quadrato nero e i valori sono considerati ottimizzati. 
 

 
Figura 22-Esempio contrassegno cella 

 

8.5.10 Smarcare celle  

Per deselezionare le celle della tabella: 
1. Seleziona le celle 
2. Premere CANC 

◆ I siti non sono contrassegnati e il quadrato nero viene rimosso.  
 
 
 

 
Figura 23-Riepilogo 
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8.6 COMPONENTE TABLE TARGET 

Il componente Table Target viene comunemente utilizzato durante la taratura del motore. L'intero 
componente rappresenta la tabella attualmente selezionata. Il quadrato rosso fluttuante mostra dove  
il valore del canale si trova rispetto al punto attualmente selezionato della tabella. 
 
 

 
Figura 24-Table Target 

 

L'uso più comune del Table Target è durante la calibrazione di un motore a banco prova. Il preparatore 
si porta sulla cella che vorrebbero ottimizzare utilizzando l’acceleratore oppure con il freno in modo da 
posizionare il quadrato al centro della casella del componente Table Target ( diventa verde ). 
Quando il quadrato è al centro del target, significa che il valore live del motore è lo stesso del valore della 
cella selezionata. 

8.7 COMPONENTE CHANNEL LIST 

La lista canali (Channel List) visualizza un elenco filtrato ed ordinato di canali, mostrando i loro valori in 
tempo reale. 
 

 
Figura 25-Esempio lista canali 

 
L'elenco può essere filtrato tramite la finestra proprietà canali e la barra di ricerca. Se non visibile, la barra 
di ricerca può essere impostata utilizzando le Proprietà 
 
Nota: La lista canali mostra valori in tempo reale, quindi non possono essere modificati. 
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8.8 COMPONENTE TIME GRAPH 

Un componente Time Graph tiene traccia e visualizza i valori in tempo reale dei canali selezionati. 
 

 
Figura 26-Esempio Time Graph 

 
Il grafico utilizza il tempo come asse X e l'intervallo dei singoli canali per ciascun gruppo di canali attivo 
per l'asse Y. 
È possibile mettere in pausa e riavviare il grafico temporale (premendo il tasto T). Questo permette 
di mettere in pausa e analizzare velocemente i dati o un fenomeno appena trascorso 
 
Le proprietà permettono di: 
 

• Aggiungere e rimuovere gruppi di canali e canali da visualizzare 

• Modificare l'ordine dei canali e dei gruppi di canali 

• La disposizione dei canali 

• Varie opzioni di visualizzazione come informazioni sugli assi, intervalli e unità 
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8.9 COMPONENTE SCATTER PLOT 

Il componente grafico a dispersion.e (scatter plot) è un componente che viene utilizzato per mostrare una 
tendenza di due canali correlati  
Un uso comune di questo tipo di grafico è quello di tracciare la relazione tra il canale boost e RPM o per 
mostrare come la pressione dell'olio cambia con la temperatura dell'olio. 
 

 
Figura 27-Esempio Scatter Plot 

Il grafico a dispersione campiona i due canali selezionati e traccia l'intersezione tra i due valori del canale 
sul grafico. Ogni valore tracciato rimarrà visualizzato sullo schermo per una durata configurabile. 
 

8.10 COMPONENTE HISTOGRAM 

Il componente Istogramma (histogram) fornisce una rappresentazione grafica relativa alla percentuale di 
tempo in cui il canale è stato all'interno di un intervallo di valori specifico. 
Ad esempio, la quantità di tempo in cui un motore è stato in piena potenza. 
 

 
Figura 28-Esempio Histogram 

 

8.11 COMPONENTE COLOUR GRAPH 

Il componente grafico a colori (colour graph) mostra una rappresentazione colorata di un canale nel 
tempo. 
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L'esempio seguente mostra il grafico del colore relativo alla temperatura del motore nel tempo, in cui il 
motore si avvia a freddo, si riscalda, si raffredda e così via. 
 

 
Figura 29-Esempio di Colour Graph 

 
Questo tipo di grafico è utile, ad esempio quando si confrontano più temperature di scarico. 
Quando i cilindri vengono visualizzati contemporaneamente su questo grafico, viene fornita una 
rappresentazione visiva che mostra come ciascuno di essi stia salendo di temperatura rispetto agli altri  

8.12 COMPONENTE NOTES 

Il componente Notes è un metodo che consente sia allo sviluppatore dell'applicazione che all'utente finale 
di lasciare note informative all’interno di un Worksheet. 
 

 
Figura 30-Esempio di Notes 
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8.13 COMPONENTI GAUGES 

I componenti Gauges vengono forniti per visualizzare i canali in modo rapido ed immediato. 
Ad esempio, con un colpo d'occhio è possibile vedere il regime del motore, la temperatura dell'aria in 
ingresso e la pressione dell'olio. 
I tipi di indicatori sono qui riportati: 
 

Numeric Bar Dial Status Light 

 
Visualizzazione numerica 
di un canale 
 

 
Istogramma 
verticale o 
orizzontale 
colorato 
 
 

 
Quadrante analogico 
 

 
Spia per un particolare 
canale o condizione 
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8.14 PROPRIETA’ DEI COMPONENTI 

Per accedere alle proprietà dei singoli componenti, premere di destro sul singolo componente e 
selezionare Proprietà (F5): 
 
     

 
Figura 31-Esempio proprietà Time Graph 

 

Nelle proprietà si possono aggiungere/eliminare canali, selezionare font e tante altre opzioni a seconda 

del componente selezionato. 
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8.15 CAMBIO UNITA’ DI MISURA DI UN CANALE 

Selezionare il canale desiderato → premere di tasto destro → Selezionare la voce Active Item e a seguire 

Properties 

 

Figura 32-Proprieta canale unità misura 

Entrare e selezionare l’unità di misura dalla voce Unit 

 

Premere OK e salvare il package 
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9 USANDO M1 TUNE 

Per utilizzare efficientemente M1 Tune, è importante comprendere i seguenti elementi: 
 
 

• Configurazione proprietà canali 

• Usare la registrazione di dati live 

• Usare la Quick Lambda Function “Q” 

• Usare le funzioni “W” e “L” per intervenire sul carburante 

• Usare la funzione di calibrazione “Q” 

• Apportare modifiche alla ECU mentre è in funzione 

• Salvare modifiche sulla ECU mentre è in funzione 
 

9.1 Gestione delle proprietà canali globali 

All'interno di M1 Tune, l'utente ha la possibilità di configurare qualsiasi canale in base alla propria 
necessità in merito all’unità di misura o di formato. 
 
Per accedere a tale schermata: Tools → Show Data Properties 
 
La finestra mostra tutti i canali in uso nel Package corrente e le sue impostazioni. 
Queste proprietà del canale sono globali e qualsiasi modifica apportata si rifletterà in tutta l'applicazione. 
 

 
 

 
Figura 33-Data Properties 



 

 

P.IVA/CF 02927690368 - CCIAA MO 343099; Cap. Soc. 32.000 iv; Reg. Imp. MO n. 02927690368 

9.2 Impostare il limite del canale 

Oltre ad altre impostazioni, la finestra Proprietà Canale Globale controlla anche i limiti dei canali. 
I limiti di avviso creati per un canale sono coerenti in tutta l'applicazione. 
Nota: Questi limiti di visualizzazione dei canali si aggiungono ai limiti dei parametri alto e basso 
visualizzati nell'elenco errori. 
 
Esempio di pressione dell'olio: 
Se è installato un sensore di pressione dell'olio con un limite inferiore di 20kPa, come mostrato qui di 
seguito, in qualsiasi posizione all'interno di M1 Tune in cui viene mostrata la pressione dell'olio, il valore 
viene visualizzato in rosso rispetto al colore predefinito. Questo è mostrato nel grafico a barre (per 
i grafici a barre la barra stessa è rosso anziché il numero) e nell'elenco canali come riportato qui di 
seguito. 

 

 
Figura 34-Esempi Warning Channel 

 9.3 Modifiche in real-time e salvataggio dati 

Quando si modificano i parametri in centralina attraverso M1 Tune, tutte le modifiche apportate sono "In 
diretta", ovvero la modifica avviene in tempo reale nel momento in cui viene inserito il nuovo 
valore. Questo significa che quando il motore si trova in un sito ben determinato, e il valore di quel sito 
viene modificato, la ECU inizierà immediatamente a utilizzare il nuovo valore. Per mantenere le modifiche 
in ECU è necessario salvare il package. Nel caso in cui la ECU venga riavviata senza salvare 
vengono caricati gli ultimi valori salvati. 
Se viene scollegato il cavo ethernet di comunicazione senza salvare, la ECU riinizierà ad applicare 
gli ultimi valori salvati. 
 
In alcuni casi, un cambiamento dal vivo non è possibile. Ciò si verifica quando un parametro dipende da 
altri parametri sottostanti, che richiedono l'aggiornamento simultaneo. In queste circostanze per rendere 
effettiva la modifica è necessario riavviare la ECU. 
Questi parametri sono identificato da una bandiera rossa. Nel momento del salvataggio viene 
richiesto un riavvio automatico della ECU. 
 



 

 

P.IVA/CF 02927690368 - CCIAA MO 343099; Cap. Soc. 32.000 iv; Reg. Imp. MO n. 02927690368 

 

 

 

Figura 35-Esempio parametri che richiedono riavvio ECU 

9.4 Controllo dati live e in pausa 

M1 Tune è in grado di visualizzare i dati in tempo reale. I valori vengono visualizzati in una combinazione 
di grafici e indicatori come evidenziato precedentemente. Visualizzare i dati in tempo reale consente il 
monitoraggio del motore in funzione e delle strategie ad esso associate. 
 
A volte, potrebbe essere necessario tornare indietro nel tempo per guardare un evento accaduto 
durante la visualizzazione dei dati. Per fare ciò, è necessario utilizzare il componente Time Graph. 
Per visualizzare un evento passato è necessario mettere in pausa la visualizzazione live usando 
il pulsante Pause nel menu barra degli strumenti o premendo T (la registrazione di dati in diretta 
continua a verificarsi, ma lo schermo non è aggiornato).  
Quando i dati live di M1 Tune sono in pausa, l'icona "Connected" lampeggia e i valori dei canali vengono 
messi in pausa in tutti i Workbook. 
Dopo aver messo in pausa, è possibile spostare il cursore nel grafico temporale sul punto nel tempo che 
deve essere esaminato (tutti i componenti visualizzano i valori come erano per il tempo selezionato). Da 
questa posizione, è possibile ingrandire e rimpicciolire per guardare i dati in modo più dettagliato, come 
in I2. 
 
L'uso della funzione pausa è un modo rapido per lavorare durante una messa a punto del motore. Il 
motore può essere accelerato fino al suo limitatore e, una volta fatto, i dati live di M1 Tune possono 
essere messi in pausa. Questo permette al calibratore di tornare indietro ed esaminare in dettaglio la 
rampa e tutti i valori da quel punto in poi. 
 
Per riprendere la visualizzazione dei dati in tempo reale, ripremere il pulsante Pausa o tasto T. 

9.5 Funzione di taratura Q 

Il tasto Q esegue funzioni speciali su parametri e tabelle. 
La funzione è diversa a seconda dell'elemento selezionato. 
 
La funzione Q ora può eseguire una calibrazione su qualsiasi parametro o tabella in cui è mostrata 
l'icona Q. 
 
Per esempio quando si seleziona l'elemento e si preme il tasto Q, M1 Tune esegue una funzione speciale 
che calibrerà quel determinato valore. 
Un esempio è la calibrazione del GRIP. Il processo per questa calibrazione è come segue: 
 
1. Selezionare il parametro Throttle Grip Sensor Main Offset → premere Q per calibrare il valore a GRIP 

tutto chiuso 
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2. Selezionare il parametro Throttle Grip Sensor Main Scale → premere Q per calibrare il valore a GRIP 
tutto aperto 
 
 

 
Figura 36-Esempio utilizzo tasto Q 

 

9.5.1 Funzione Quick Lambda ‘Q’ 

Quando si utilizza Q sulla tabella Fuel Volume, la funzione eseguita è Quick Lambda. 
La funzione Quick Lambda, consente automaticamente di aggiustare il valore di benzina iniettata per 
portare il motore al target lambda desiderato (Fuel Mixture Aim Main). 
 
Scorrendo a banco tutti i valori di RMP e farfalla si riesce quindi ad aggiustare la mappa benzina molto 
velocemente. 

 
Tale funzione è possibile utilizzarla anche con i dati in Pausa ( tasto T )! 

9.6 Funzione Quick Lambda ‘W’ 

Tale funzione è molto simile alla pressione del tasto Q, ma a differenza modifica 4 celle in una volta sola. 
Utile in fase di sgrossamento mappa benzina e inizio del tuning. 

9.8 Funzione Lambda Was ‘L’ 

Se la tabella del carburante deve essere ottimizzata utilizzando l’acquisizione dati I2 a posteriori, si può 
utilizzare la funzione Lambda Was. 
Premendo sulla tabella Fuel Volume di un package Offline, il tasto " L " compare una finestra dedicata. 
L’utente deve inserire il valore di lambda reale letto dall’acquisizione dati e automaticamente M1Tune 
aggiusta il valore di carburante per far si che raggiunga il valore di target lambda desiderato. 
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Figura 37-Riepilogo tasti strategici 

 

9.9 Visualizzazione tensione pin in real time 

A volte è necessario conoscere la tensione effettiva che si trova su un particolare pin della ECU. 
 
Per fare ciò: 
 
1. Selezionare dal menu Online » Monitor Inputs / Outputs 

◆ Viene visualizzata la finestra monitor che mostra la tensione degli input ECU utilizzati: 
 

 
Figura 38-Monitor tensioni pin digitali 
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Figura 39-Monitor pin analogici 
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9.10 Visualizzazione pin I/O utilizzati 

La configurazione dei pin della ECU viene determinata quando il package viene configurato la prima 
volta. 
Il Wiring Summary mostra il numero di pin utilizzato per ciascun input e output, insieme al suo tipo, 
nome e abbreviazione. 
Gli input non utilizzati vengono visualizzati senza alcuna informazione nella colonna Usage. 
Per visualizzare Wiring Summary: 
 
1. Selezionare il menu Help » Package Wiring... 

◆ Viene visualizzata la finestra Wiring Summary, ad esempio: 
 

 
Figura 40-Esempio Wiring Summary 

 
2. Per stampare il Wiring Summary, utilizzare il pulsante stampa in alto a sinistra della finestra. 
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9.11 Elenco degli stati e gestione dell’errori 

I sensori non in uso devono essere disabilitati, ove possibile, in modo che gli errori ad essi associati non 
vengano considerati dal sistema. 
M1 Tune rileva che un canale è andato in errore quando il suo valore va oltre il limite configurato nei 
parametri del canale. ( Diagnostic ) 
Se è presente un valore di deafult, il sensore acquisirà come valore quello di default. 
 
Di seguito viene mostrato come vengono visualizzati questi errori. 
 

 
Figura 41-Esempio schermata errori 

 
Quando si verifica un errore, il parametro del canale e il suo valore vengono aggiunti a un elenco di 
Stato. 
Viene visualizzato il seguente popup per notificare all'utente la modifica all'elenco degli errori. 
 

 
Figura 42-Pop-up errori 

 
Per visualizzare la finestra di Stato premere il tasto F3. 
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Figura 43-Finestra Stato 

 
La finestra Stato mostra tutti gli attuali Errori e lo Stato dei canali.  
A volte, l'errore è attivo solo per un breve periodo e potrebbe non apparire nella finestra quando viene 
aperta. In questo caso, selezionare la scheda Event Log per visualizzare la cronologia degli errori/stati. 
 

 
Figura 44-Esempio Event Log 
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9.12 Elementi non validi 

Quando viene creato un pacchetto, i parametri e le tabelle vengono normalmente impostati con una 
convalida dell'input. 
La convalida imposta dei limiti alti e bassi relativi al parametro. Se il parametro non dovesse rientrare nei 
limiti viene segnalato in M1Tune con un simbolo di divieto rosso. 
È possibile cercare tutti i parametri non validi utilizzando Tools >> Show Invalid Configuration Data 
Summary oppure premendo il tasto F7. All'interno di tale finestra è possibile aggiornare i parametri con 
valori validi. 
 

 
Figura 45-Esempio elementi non validi 

 

 
Figura 46-Esempio Invalid Configuration Window 
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9.13 Migrazione dei Dati 

La migrazione di dati permette di “copiare” i dati di tuning da un package all’altro ( esempio 
aggiornamento di firmware ). 
Esistono due metodi per migrare i dati, descritti qui di seguito. 

9.13.1 Migrazione automatica 

Migra automaticamente tutti i dati da un Package ad un altro. I parametri che non possono essere migrati 
sono evidenziati e mostrati a fine procedura. 
 
La migrazione è relativa a tutti gli elementi del Package: 
 

• Tabelle 

• Parametri 

• Dettagli pacchetto utente 

• Impostazioni acquisizione dati 

• Workbook 
 

9.13.2 Migrazione manuale  

La migrazione manuale permette di copiare da un Package ad un altro solo alcuni parametri/tabelle. 
 
Seguire la seguente procedura: 
 
1.    Aprire un Package offline o connettersi online ad una ECU. 
 
2.    Selezionare il menu File >> Add Compare Package 
 
Nella modalità di confronto, l'utente può visualizzare i package attraverso i soliti componenti di 
visualizzazione ( worksheet ). 
 
Un metodo più semplice per verificare le differenze: 
 

3. Selezionare Tools >> Compare Data  
 
4. Evidenziare in alto Diffs, per abilitare visualizzare solo i componenti differenti 

 
5. Se si desidera copiare i dati dal Package di destra a quello di sinistra, cliccare sulla freccia blu 
a centro finestra. 
 

6. Premere su Close una volta completato 
 

7. Chiudere il Package utilizzato per la comparazione File >> Close Compare Package 
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Figura 47-Finestra compare 

10 CONFRONTO DI PACKAGE 

Per confrontare due package, seguire i punti 1,2,3,4,6,7 della sezione Migrazione Manuale. 

11 ACQUISIZIONE DATI 

È possibile configurare l’acquisizione dati fino ad 8 differenti slot. Suddividere i dati in slot richiede 
l’acquisto della licenza per il TEAM LOGGING. 
 
Solo in caso di acquisto di TEAM LOGGING è possibile acquisire i dati e visualizzare sul software I2. 
La ECU permette all’utente di selezionare quali canali memorizzare e a che frequenza: trascinare il 
canale dalla lista completa di sinistra, alla frequenza desiderata a destra. 
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Figura 48-Set-up datalogging 

 
L’acquisto del TEAM LOGGING è consigliato per poter analizzare in dettaglio i dati e affinare i 
parametri delle strategie e il tuning del motore. 
 

11.1 Download dei dati 

Per eseguire il download dei dati seguire le istruzioni sotto riportate: 

Selezionare l’icona ‘Retrieve  Logged Data’ 

 

Figura 49-Retrive Logged Data 
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Selezionare la ECU connessa al computer 
 

 
Figura 50-Selezione ECU 

 
Selezionare il data logging system da scaricare (nel nostro caso data logging system 2) e selezionare  
dove salvare i dati 
 

 
Figura 51-Data Logging System 

 
Cancellare i dati in memoria una volta scaricati 
 

 
Figura 52-Erase dei dati 
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Scrivere i commenti a corredo del file e creare la cartella della sessione nel browse selezionato in 
precedenza 
 

 
Figura 53-Commenti dati 

 
 
Una volta eseguito il download si ha la possibilità di visualizzare i dati utilizzando il software I2PRO o 
I2STD. 

12 SICUREZZA 

La centralina offre un sistema di sicurezza avanzato basato su un sistema crittografato. 
 
Attualmente sono presenti tre livelli di sicurezza utente: 
 
1. MoTeC 
2. FMI 
3. Guest 
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La schermata che viene visualizzata ogni volta che ci si connette alla ECU è la seguente: 
 

 
Figura 54-Schermata di accesso 

 

Username e password di default: 

Username: Team 

Password : Team 

 

L’utente ha facoltà di cambiare autonomamente la password, recandosi in Online→Edit Password 


